Recent Changes - Search:

TestbedClients

Following, an overview of the TNETMON GUI is provided.

General:

1. Select File -> Connect -> SmartCCSR -> Floor this will allow you to show the current deployment on the two CCSR floors. During and after an experiment the nodes visualized using the Topology tab are only those selected for the experiment, so in order to refresh the topology you need to repeat the same selection File -> Connect -> …

2. Log-in into the system before running experiment. Just select the right button and confirm.

Attach:1TNETMON

Running a simple experiment:

3. Select a node simply clicking on it. You should be able also to select multiple nodes holding the Shift key and clicking on the desired nodes or just dragging an area around them. In this case if you want to run an experiment that simply shows the collection of data using the infrastructure, select node 118. I will provide you with the list of images corresponding to a given experiment and a list of nodes suitable for those.

4. Select the button for configuring the experiment. In this new window you can also add or remove nodes to the experiment.

5. Click next in order to visualize the different preconfigured experiment we have already created. Each different experiment is related to a different set of properties characterizing the experiment that you can configure and a different way to visualized the received data. A plugin mechanism has been defined in order to facilitate these operations and to provide the user with some primitive for interacting with the node, parsing the message, interact with the topology (coloring nodes, changing their shape etc etc).

Attach:2TNETMON

6. Select the type of experiment you want to run. Select now the Simple Expr that just gives to user the possibility to flash a given image that generate some debug message and store them in the database. This is the most simple and the most generic one, useful if we are interested only to generate some data, without needs to visualize them but just for collecting log to post process later with other tools. Clicking on the next button you can also configure the other provided options for the experiment, such as in this case upload the image you want and/or reset the node. In this case for the node 118 an image for this experiments is already preloaded on the node, so eventually you can just reset the node. The last window (not shown here) gives you the possibility to select the duration of the experiment. The default value (1 minute) is enough for this experiment. When you run more complex experiment you should take into account in the reservation time also some additional time for flashing the nodes. When everything is done and the experiment starts the focus should move to the topology tab, showing the selected nodes. Through the Logs tab you can show the flow of incoming message. Throughout the plugin mechanism is also possible to show the message already parsed (instead of its binary representation) based on its tinyos type and format.

Replay of an experiment:

If you want to replay an experiment, first of all you need to be sure that the steps 1 and 2 have been performed. One time for every session is enough.

Attach:3TNETMON

7. Select the green button for opening the list of currently stored experiment. During an experiment you can use this button also for checking the status of a running experiment. You can see additional lines showing the experiment currently running and its status (i.e., RUNNING). You can also refresh its status (9). Eventually you can also select and remove old experiments from the experiment DB, but at this time please don’t do it.

8. Select the experiment you want to replay. Usually I select the ROME experiment performed at 4pm on October 4th. You can also show the experiment Energy Meter. This one shows the collection of information coming from our energy meter/sensor board, giving to the selected nodes different colors based on the detect value of light (if above a threshold the node is yellow), the value of the PIR (if a presence is detected the node is green), while if there is some load connected to the energy meter, the node is red (this event however didn’t happen during this experiment). Finally, the Link Calculation Experiment shows the link existing between the selected nodes, based on a given packet error rate threshold that you can select on the next window. The ROME and Link experiment have been performed on a similar set of nodes on the second floor. The Energy Meter has been performed on the nodes in my room, with me roaming around the room.

9. Refresh is not used during the experiment replay but only in the case explained before.

10. In the next window you can select the required parameter for the experiment replay, such as the Packet Error Rate for the Link experiment and the replay speed for all the experiment.

11. Just to be sure, every time you want to perform other action, please remind to stop the replay of an experiment using the right (red) button.

Additional info:

• Before running the ROME experiment check that the ROME plug in (for the visualization tool) has been enabled. You can do this through the Edit menu, selecting Preferences and by toggling the ROME plugin in the plugin window.

• For any other experiment please check the ROME plugin is disabled, because otherwise it will overwrite any interaction with the topology.

• The Topology Info tab can be minimized or closed for showing better the deployment. It can be also moved in another window, by clicking the adequate button.

• During a ROME experiment you can also select the new created ROME tab and show some real-time computed metrics, such as latency and eventually the value of light collected by each source.

Edit - History - Print - Recent Changes - Search
Page last modified on November 19, 2012, at 08:40 PM